Results 1 to 6 of 6

Thread: No radio check or audio after latest crew chief update for Realtek Audio speakers

  1. #1
    Junior Member
    Join Date
    Apr 2021
    Posts
    3

    No radio check or audio after latest crew chief update for Realtek Audio speakers

    Hi There,

    Since latest update my speakers connected to realtek "usb" (mobo chip actually) no longer work. I change output to my razer headphones and it works fine. There has been no changes to underlying drivers, unclear whats causing this.

    I have so far tried:
    - Full uninstall and reinstall of CC
    - Delete all appdata of CC and redownload voice packs etc
    - Reinstall audio drivers
    - Delete speaker in device manager and then reinstall (with required restarts)

    Still no joy, here are the log outputs on CC which don't appear to have any errors to me....

    Code:
    20:21:23.232 : Loading screen opened
    20:21:23.233 : Set iRacing mode from previous launch
    20:21:23.235 : Starting app.  Version: 4.16.1.4
    20:21:23.296 : Device name: Speakers (2- Razer BlackShark V2 Pro) Guid: {0.0.0.00000000}.{7423c565-003e-4cd9-9f1b-85a812578cf9} DeviceWaveId 0
    20:21:23.296 : Device name: Speakers (Realtek USB Audio) Guid: {0.0.0.00000000}.{8a750d94-b43d-47ef-a770-0de741e197e9} DeviceWaveId 1
    20:21:23.296 : Detected saved message audio output device: Speakers (2- Razer BlackShark V2 Pro)
    20:21:23.296 : Detected saved background audio output device: Speakers (Realtek USB Audio)
    20:21:23.360 : nAudio output interface: WAVEOUT
    20:21:23.564 : Using sound pack version 188, driver names version 140 and personalisations version 147
    20:21:23.568 : Preparing sound effects
    20:21:23.570 : Prepare sound effects completed
    20:21:23.570 : Preparing driver names
    20:21:23.595 : Prepare driver names completed
    20:21:23.596 : Preparing personalisations for selected name Ken
    20:21:23.598 : Spotter Jim (default) has oval-specific sounds - these will be used for tracks marked as 'oval'
    20:21:23.599 : Prepare personalisations completed
    20:21:23.600 : Preparing voice messages
    20:21:23.717 : Prepare voice message completed
    20:21:23.718 : Finished preparing sounds cache, found 9992 driver names and 3025 sound sets. Loaded 436 message sounds
    20:21:23.718 : 324 sounds have personalisations
    20:21:23.766 : Reading driver name mappings
    20:21:23.767 : Read 2164 driver name mappings
    20:21:23.767 : Reading driver name mappings
    20:21:23.768 : Read 422 driver name mappings
    20:21:23.813 : Loading controller settings
    20:21:23.813 : Load controller settings complete
    20:21:23.908 : Loading screen closed
    20:21:23.913 : Checking for updates
    20:21:24.139 : Took 0.42s to lazy load remaining message sounds, there are now 9547 loaded message sounds
    20:21:24.139 : Skipped 101 sweary sounds
    20:21:24.958 : Got update data from primary URL: https://thecrewchief.org
    20:21:24.961 : Check for updates completed
    20:21:40.094 : Pausing console scrolling
    20:21:40.094 : Using game definition iRacing
    20:21:40.096 : Loading user-configured command macros from Documents/CrewChiefV4/ folder
    20:21:40.102 : Loading default command macros from installation folder
    20:21:40.108 : Free text action macro, text = Sorry, my bad
    20:21:40.108 : Found FREE_TEXT for commandSet iracing version
    20:21:40.108 : Free text action macro, text = Good pass
    20:21:40.108 : Found FREE_TEXT for commandSet iracing version
    20:21:40.144 : Loaded 142 default car class definitions and 0 user defined car class definitions
    20:21:40.163 : No user defined landmarks found
    20:21:40.166 : ThreadManager: Wating for root threads to start...
    20:21:40.166 : ThreadManager: Root threads started
    20:21:40.179 : serverTransmitMaxCars = 63
    20:21:40.179 : is360HzTelemetry = False
    20:21:40.180 : Starting queue monitor
    20:21:40.181 : Monitor starting
    20:21:40.183 : Using NumberReaderEn for soundPackLanguage en
    20:21:40.211 : Loading user-configured chart subscriptions from Documents/CrewChiefV4/ folder
    20:21:40.214 : Added 4 common subs to 37 game-specific subs
    20:21:40.215 : Polling for shared data every 16ms
    20:21:40.629 : Playing sounds, events: COMPOUND_smoke_test_chief
    20:21:40.629 : (radio_check/test)

  2. #2
    Junior Member
    Join Date
    Apr 2021
    Posts
    3
    Resolved by disabling nAudio in properties per another thread.

    Means you lose drop down menu for output device. I alternate between using my speakers and headset depending if I'm playing with others on discord, but I can just switch my default audio device using soundswitch which works better for me anyway as that is how I have iRacing setup - use default windows sound input/output, then control that with a hotkey for soundswitch to swap between devices.

  3. #3
    Junior Member
    Join Date
    Feb 2022
    Posts
    7
    How does one do that?

  4. #4
    Junior Member
    Join Date
    Apr 2021
    Posts
    3
    Quote Originally Posted by Emirdepassy View Post
    How does one do that?
    You need to open properties and scroll right down and uncheck "Use nAudio for playback (boolean)"

    Name:  Screenshot 2022-04-14 095337.jpg
Views: 1736
Size:  19.5 KB

  5. #5
    Junior Member
    Join Date
    Feb 2022
    Posts
    7
    Thanks.... actually i misread.. my problem is that chief doesn't hear me .. i checked that my microphone works in windows sound settings

  6. #6
    Junior Member
    Join Date
    Feb 2024
    Posts
    3
    that fixed my issue.
    Thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •