I went through my settings in Windows 10 and changed the sound for CC to use my Logitech headphones. I want my engine and other sounds to come through the computer and only CC to come through the headphones. It worked at first and then it stopped working. Now the CC sound goes through the system default instead of my headphones, even though I have Windows 10 system settings pointing at the headphones for the CC app. Any help would be great. Thanks.