Results 1 to 7 of 7

Thread: Not recognizing macros

  1. #1
    Junior Member
    Join Date
    Dec 2018
    Posts
    3

    Not recognizing macros

    I play mostly project cars

    It seems the macros are broken for me.

    I used to be able to ask for fuel as such "Add fuel 10 Liters" or Pit request by saying "Box this lap"

    Neither is working. I just get a reply that crewchief doesn't understand. All other commands seem totally fine.

    I thought maybe it wasn't loading the macros json correctly so I tried copying that to documents crewchief folder but that hasn't helped either.

    I have also tried a few different voicepacks. En-US and EN-CA and neither helped.

    Uninstalling and reinstalling Crewchief along with the voicepacks and runtimes hasn't helped either.

  2. #2
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    1,313
    There might be something in the console output. Fire up the app, select the game and press 'Start' - this will load the macro file and report any errors. Post the entire log here please.

    Is this pcars or pcars2?

  3. #3
    Junior Member
    Join Date
    Dec 2018
    Posts
    3
    I am playing project cars 2. Here is the output as requested. I have bolded what appears to be the causing the issue.

    11:05:34.515 : Set pCARS (network data) mode from previous launch
    11:05:34.523 : Starting app. Version: 4.9.6.0
    11:05:34.647 : Using sound pack version 160, driver names version 134 and personalisations version 132
    11:05:34.666 : Preparing sound effects
    11:05:34.686 : Prepare sound effects completed
    11:05:34.687 : Preparing driver names
    11:05:34.711 : Prepare driver names completed
    11:05:34.722 : Preparing personalisations for selected name Phil
    11:05:34.727 : Using spotter: Phil
    11:05:34.728 : Spotter Phil has oval-specific sounds - these will be used for tracks marked as 'oval'
    11:05:34.792 : Prepare personalisations completed
    11:05:34.794 : Preparing voice messages
    11:05:36.281 : Prepare voice message completed
    11:05:36.285 : Finished preparing sounds cache, found 6608 driver names and 2705 sound sets. Loaded 398 message sounds with 391 active SoundPlayer objects
    11:05:36.286 : 248 sounds have personalisations
    11:05:36.343 : Reading driver name mappings
    11:05:36.348 : Read 2164 driver name mappings
    11:05:36.349 : Reading driver name mappings
    11:05:36.353 : Read 422 driver name mappings
    11:05:36.388 : Loading controller settings
    11:05:36.406 : Load controller settings complete
    11:05:36.452 : Attempting to get recogniser for en
    11:05:36.466 : English (Canada) - (en-CA)
    11:05:36.533 : Speech engine initialized successfully.
    11:05:36.546 : Loading all voice command alternatives from speech_recognition_config.txt
    11:05:36.652 : Attempted to initialise speech engine - success = True
    11:05:36.826 : Checking for updates
    11:05:37.215 : Got update data from primary URL: **no URL allowed in post**
    11:05:37.223 : Check for updates completed
    11:05:55.270 : Pausing console scrolling
    11:05:55.273 : Using game definition pCARS (network data)
    11:05:55.349 : Loading user-configured command macros from Documents/CrewChiefV4/ folder
    11:05:55.625 : No macro voice triggers defined for the current game.
    11:05:55.678 : Loaded 96 default car class definitions and 0 user defined car class definitions
    11:05:55.713 : No user defined landmarks found
    11:05:55.715 : Listening on default audio input device
    11:05:55.717 : Running speech recognition in 'hold button' mode
    11:05:55.719 : ThreadManager: Wating for root threads to start...
    11:05:55.723 : ThreadManager: Root threads started
    11:05:55.741 : Starting queue monitor
    11:05:55.743 : Monitor starting
    11:05:56.091 : Playing sounds, events: COMPOUND_smoke_test_chief
    11:05:56.092 : (radio_check/test)
    11:05:56.554 : Polling for shared data every 100ms
    11:05:56.559 : Initialising...
    11:05:56.563 : Listening for UDP data on port 5606
    11:05:56.872 : There are 1 more events in the queue, playing them...
    11:05:56.873 : Playing sounds, events: COMPOUND_smoke_test_spotter
    11:05:56.873 : (radio_check_Phil/test)
    11:05:56.874 : PlaybackModerator: Injecting: end_bleep and alternate_short_start_bleep messages. Spotter interrupted Chief.
    11:05:58.499 : PlaybackModerator: Closing radio channel as Spotter
    11:05:59.126 : Took 22.84s to lazy load remaining message sounds, there are now 7743 loaded message sounds with 396 active SoundPlayer objects

  4. #4
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    1,313
    It's not working because you're using pcars 1 udp mode. Any reason why you're not using pcars2 shared memory mode? It really is much better.

  5. #5
    Junior Member
    Join Date
    Dec 2018
    Posts
    3
    Thanks Chief! I completely forgot I changed it when i was testing some dashboard apps. Everything is back to normal now.

  6. #6
    Junior Member
    Join Date
    Jun 2019
    Posts
    3

    unhandled exception when starting command macro editor

    Quote Originally Posted by Shiska View Post
    Thanks Chief! I completely forgot I changed it when i was testing some dashboard apps. Everything is back to normal now.
    I tried to command macro editor but each time i click on the button i get unhandled exception..

    i tried to delete the json but it did not help the json gets recreated

    thank you

  7. #7
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    1,313
    clicking the "command macro editor" button? It works for me - which json did you delete? saved_command_macros.json in Documents/CrewChiefV4/ ?

    which version of the app are you on?

    Do you have the actual error message or EventLog .Net error?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •