Results 1 to 7 of 7

Thread: App Lag On Newer Versions

  1. #1

    App Lag On Newer Versions

    For the last three weeks, I've had an issue with the app where it begins giving me voice messages several seconds after it normally should, such as exiting pit road or having an off. It then stops responding to my button on my wheel to initiate voice command. When I look in the log, there are multiple errors related to "nAudio". This does not begin immediately, and only after running for a while - anywhere from 10 minutes to an hour. I have to completely close and relaunch the application to restore full operation - simply pressing "stop" does not resolve the issue.

    Help please.

  2. #2
    VP PR Manager Sparten's Avatar
    Join Date
    Feb 2017
    Posts
    439
    Dont use nAudio, windows 10 now lets you select witch sound device CC should output to. Do the following: right click your speaker in tray ->Open Sound Settings->Other sound options->app Volume and device preferences, and set witch device you want CC to play or listen to make sure the app is running what your make the changes in sound settings else it wont appear there.

  3. #3
    That option doesn't work for me, though. I send CC output to my headset - when using Windows 10 it only send the background sounds to my headset - the actual voice chat goes to my "car" speakers. The issue there is that CC splits the sounds into two separate outputs. Is there a way to configure the speech and background sounds to a single output?

  4. #4
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    1,121
    sorry for the delay here...

    CC uses windows media player for the background sounds, and a built in .Net SoundPlayer for the messages so they're always separate. If the windows 10 sound device stuff doesn't work, and nAudio also doesn't work, one possible (grotty) workaround is to set your headset to be the default audio device, then launch and start CC. Then change your default audio device to whatever you want the game to use and launch the game. CC should keep outputting to the device that was the default at the point you launched it.

    You need to disable the nAudio options to make this work

  5. #5
    That's what I've done for the time being, is to set my headset as the default. Can you make it an option to not split the output?

  6. #6
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    1,121
    Not sure it's possible with the current implementation. The background is windows media player, messages are .Net Sound player. Media player is good for long MP3 sounds but tends to cut off the first and last tenth of a second of any sound, so it's no good for message sounds.
    .net player can only play 1 sound at a time so can't be used to play message and background.

    Naudio can play concurrent streams but is far too buggy to really rely on

  7. #7
    I was doing some research on nAudio and it seems like the further Windows goes with development of 10 (and any other OS) nAudio will work less and less - based on what I read, any way. I honestly can't remember if it was a CC update where this started or a Windows update, but based on what I read I am leaning towards a Windows update causing this issue.

    I'll keep using my headset as my default device until you have whatever epiphany is required to solve this (I tend to have programming epiphanies in the shower lol)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •