Results 1 to 9 of 9

Thread: BUG! speech recognition forced to en-AU

  1. #1

    Exclamation BUG! speech recognition forced to en-AU

    hey guys, after today's update CC's speech recognition stopped working. I bashed my head wondering what went wrong with my system, then I noticed this line in the startup console

    Code:
    04:32:18.990 : Load controller settings complete
    04:32:19.179 : Attempting to get recogniser for en
    04:32:19.196 : English (Australia) - (en-AU)
    04:32:19.250 : Success
    04:32:19.251 : Loading all voice command alternatives from speech_recognition_config.txt
    I'm using the italian pack, and even if I have it-IT written in the speech recognition box as usual, now CC won't understand anything correctly, unless I use a very weird british accent, which confuses CC even more.

  2. #2
    VP PR Manager Sparten's Avatar
    Join Date
    Feb 2017
    Posts
    430
    Let me try and get this right you want to speak Italien to CC, or just English with Italien accent ?, if its the latter, then try and type only "IT", in the propertie(yes we changed some stuff).

    If you are using Italien language pack called something like MSSpeech_SR_it-IT_TELE.msi then you will need to
    locate
    and edit C:\Program Files (x86)\Britton IT Ltd\CrewChiefV4\speech_recognition_config.txt line 19
    and change the language from "en" to "it".
    Last edited by Sparten; 07-06-2018 at 03:40 AM.

  3. #3
    Quote Originally Posted by Sparten View Post
    Let me try and get this right you want to speak Italien to CC, or just English with Italien accent ?, if its the latter, then try and type only "IT", in the propertie(yes we changed some stuff).
    wait, I can do that?? I switched to the italian pack because the voice recognition just didn't want to understand me right! anyway I just did that and CC got mad at me:

    Code:
    05:35:24.482 : Attempting to get recogniser for en-IT
    05:35:24.500 : Failed to get recogniser for en-IT
    05:35:24.500 : Attempting to get recogniser for en
    05:35:24.503 : English (Australia) - (en-AU)
    05:35:24.510 : Success
    If you are using Italien language pack called something like MSSpeech_SR_it-IT_TELE.msi then you will need to
    locate
    and edit C:\Program Files (x86)\Britton IT Ltd\CrewChiefV4\speech_recognition_config.txt line 19
    and change the language to "it". I dont think this is what you want.
    oh I think the language pack already has a speech_recognition_config.txt in its own path, and it's already marked "it".

    So basically I have a speech recognition file with all the commands in italian, and I want CC to listen to my voice in italian, which was doing fine and now it doesn't anymore.
    Last edited by MatteAce; 07-06-2018 at 04:22 AM.

  4. #4
    ok now the weirdest of things just happened. I changed the "it" in both the file and in the properties menu within CC and got it to correctly recognize it! it works, cheers!


    (but the italian pack now has broken instructions...)

  5. #5
    VP PR Manager Sparten's Avatar
    Join Date
    Feb 2017
    Posts
    430
    Can you supply me with a link for the Italien pack that's not behind a site where i need to signup ? I wanna have a peek at what's going on.

  6. #6
    Quote Originally Posted by Sparten View Post
    Can you supply me with a link for the Italien pack that's not behind a site where i need to signup ? I wanna have a peek at what's going on.
    err... my account doesn't work anymore. It gives me a weird numeric error.

    EDIT: now that I think of it, it was a forum download, so no direct link. if you want to download it, you really need to sign up, sorry

    I admit it's kind of a scummy way to hide a public download for someone else's program...

  7. #7
    VP PR Manager Sparten's Avatar
    Join Date
    Feb 2017
    Posts
    430
    Looks like i'm going to have to wait for admin to appove my account, good thing i signed up with a no care password as thos guys send out your signup password in clear text over unencrypted connection, not cool at all.
    Last edited by Sparten; 07-06-2018 at 09:31 AM.

  8. #8
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    1,070
    I made a mistake on the last update - I changed the name of the option in the speech_recognition_config file from defaultLocale to language. So the app won't actually attempt to use the value from the file if it's using the old defaultLocale property. This was a dumb thing to do and I'll fix the code so it can use either value.

    As far as the external language pack goes, the idea was that this sre config file would be overridden in the sound pack download, so would be in AppData/local/CrewChiefV4/sounds/ I think.

    The reason Gianfranco put the Italian pack behind a registration process was so he could understand how many people use it and could get donations for his work. Although sending passwords in plain text emails is bonkers

  9. #9
    VP PR Manager Sparten's Avatar
    Join Date
    Feb 2017
    Posts
    430
    @MatteAce is your speech_recognition_config.txt from the Italien pack located in C:\Users\{username}\AppData\Local\CrewChiefV4\soun ds or in the directory defined in properties ?
    Edit:
    Never mind it should be fixed with new update
    Last edited by Sparten; 07-06-2018 at 09:31 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •