Results 1 to 6 of 6

Thread: Errors causing crewchief not to work with iRacing

  1. #1

    Errors causing crewchief not to work with iRacing

    I'm getting this constantly in the logs about every 2-3 seconds. Currently Crew Chief does not work with iRacing even after reinstalling. Other sims work fine.

    23:04:10.889 : Error mapping game data: Object reference not set to an instance of an object., at CrewChiefV4.iRacing.iRacingGameStateMapper.mapToGa meStateData(Object memoryMappedFileStruct, GameStateData previousGameState)
    at CrewChiefV4.CrewChief.Run(String filenameToRun, Boolean dumpToFile)

    What should be the next step to debug?

    I recently restored drive from backup, I'm wondering if it can be some sort of permissions issue. I just couldn't determine the problem from the error message.

    Using 4.9.1.4

  2. #2
    VP PR Manager Sparten's Avatar
    Join Date
    Feb 2017
    Posts
    443
    Are you tying to join a hosted session ? or a session that includes driver change ?

    If your able to replicate the error can you please try and do http://thecrewchief.org/showthread.p...f-repro-traces and upload the file here.

  3. #3
    This is my second post to enable link sharing

  4. #4
    As requested: Logfile

    This log is from one lap in a Time Trial. I have the errors present in any race or practice I run.
    Last edited by AlwaysBeApexing; 02-08-2018 at 02:04 AM.

  5. #5
    VP PR Manager Sparten's Avatar
    Join Date
    Feb 2017
    Posts
    443
    Thanks a lot, I've now tracked down the issue at least for this session type(lone practice) and it will be fixed in next update of the app.(wont take to long)

  6. #6
    Cool, let me know if you would like me to test.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •