Results 1 to 4 of 4

Thread: Slow download

  1. #1

    Slow download

    Thanks for a great program. Just want to mention that my initial download of the program and use of the auto update download links was extremely slow to me here in Australia. I was wondering if anyone else had this happen, or if something is wrong with your system. I have fastest internet available in Australia, and still these small files took almost an hour to download. My internet is working fine to any other website.
    Also i had a popup mention files such as voice and personalizations could be manually downloaded. This dispearred quickly though and i did not see it again, and could not find the individual files anywhere online.
    Last edited by Scott-Ozyguy; 01-07-2018 at 10:34 PM. Reason: Spelling

  2. #2
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    981
    the files are stored in C:\Users\[user name]\AppData\Local\CrewChiefV4\sounds\

    there are 3 sets - driver_names, personalisations, and the main sound_pack. These each have their own ..._version_info.txt file (one in the driver_names folder, one in personalisations, and one in the root of the sounds folder). You can force the app to re-download the update packages for these by reducing the number in those files by one (e.g. changing driver_names_version_info.txt so it contains 125 instead of 126).

    I've just changed the download site for the 'alternate' download locations - if you go to the app's properties screen and search for alternate, there's a property called 'Prefer alternate download locations'. If you enable this, the sound packs will be downloaded from our secondary FTP site. This is normally much slower than the primary site so isn't generally recommended, but if the primary is unusably slow for you changing to the alternate download locations may help.

  3. #3
    Junior Member
    Join Date
    Feb 2018
    Posts
    1
    Been struggling to download updates and soundpacks for about 2 weeks now here in UK via Sky... using primary site, the latest update presents a "not a valid windows executable" and fails to install (tested from 3x different setups at 3x different locations with 3x different broadband providers) - soundpacks? I've left them trying to download for several hours with no joy. Switching to alternative (you won't find it if you search for 'alternate' as advised above) and the latest update comes down fast and works fine, but personalisations and soundpacks are just as slow, I presume because they still head to primary before finally timing out and resorting to secondary, then they fly at full speed again. If alternative location is set, anyway to add into next update so that it doesn't bother trying primary first and waiting for timeout, just immediately tries alternative out for soundpacks?

    20:05:20.101 : unable to get personalisations from crewchief/downloads will try from isnais
    (Quote paraphrased to get round not being able to post links)

  4. #4
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    981
    for me, the primary site for the installer downloads it in about 3 seconds and the installer works fine. Is your anti-virus doing something weird?

    I need to separate the primary and alternate download options so you can select the location of the installer and the location of the sound pack downloads separately, which will fix your issue. It's a bit of a mess at the moment and needs some rework but it's hard to find time right now.

    If you have "use alternative download location" disabled, it'll get the installer from thecrewchief.org, and it'll get the sound packs from the secondary FTP site. If you have it enabled, it's the other way round (yes... I know this is daft). So if only the alternate ftp site is working properly for you, try running with the "use alternative download location" ENABLED. If there's a new installer, this will download OK from the alternate location. If the app says there's a new sound pack available, change this property to DISABLED (unchecked) then restart the app and download the sounds (which will pull them from the alternate ftp site). When that's done, change the property back to ENABLED again.

    Like I said, this will be reworked at some point but it's a question of getting the time. We're also in the process of sorting out bandwidth issues with our hosting so it might get better anyway

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •