Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: Can't get Voice Recognition working, please help.

  1. #1
    Junior Member
    Join Date
    Apr 2017
    Posts
    2

    Can't get Voice Recognition working, please help.

    Great application this. I'm loving it with rFactor 2.
    However I can't seem to get Voice Activation to work despite going through the necessary steps. I've installed
    SpeechPlatformRuntime.msi and then MSSpeech_SR_en-GB_TELE.msi (I used the GB variety as I am in Australia) as per the instructions. I've also tested that my default microphone is working properly so that isn't an issue.

    When I try and activate Voice Recognition in CC v4.6.4.2 I get this error message:
    14:14:08.696 : Attempting to initialise speech recognition for user specified location en
    14:14:08.703 : Success
    14:14:08.708 : Unable to configure speech engine grammar
    14:14:08.709 : Exception message: The language for the grammar does not match the language of the speech recognizer.
    14:14:08.711 : Attempted to initialise speech engine - success = False

    Loving this app, just wish I could get this feature working. Any help is greatly appreciated.

  2. #2
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    1,132
    There's a setting in the properties screen for 'speech recognition locale' or something. It defaults to 'en'. Try setting it to 'en-GB' (but en really should work - it just means 'use whatever en language is available). Perhaps your windows install expects en-AU?

  3. #3
    Junior Member
    Join Date
    Apr 2017
    Posts
    2
    Thanks so much. Changing that to en-GB worked perfectly. I had already changed my setting to GB in Windows but I suspect that if I still had it at my default, then en-AU would have worked too.
    Really appreciate your help. I'll donate to your cause to keep this app's development going. Cheers!

  4. #4

    Post

    Hi
    Its been a while but Ive come back to Raceroom and trying CChief again wow the apps been updated, but the propertise windows still a mess.
    How to find these files again? It reads,
    16:54:04.136 : Attempted to initialise speech engine - success = False
    16:54:04.162 : Attempting to initialise speech recognition for user specified location en
    16:54:04.165 : Unable to initialise speech engine with voice recognition pack for location en. Check that SpeechPlatformRuntime.msi and MSSpeech_SR_en_TELE.msi are installed.
    16:54:04.165 : Exception message: Retrieving the COM class factory for component with CLSID {49428A60-C997-4D0E-9808-9E326C178D58} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

    Now this is in windows 10 I need where to dig those Speach plaform files out of, an how to turn on shared memory Raceroom. pls
    Last edited by oOBATOo; 04-09-2017 at 05:03 PM.

  5. #5
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    1,132
    There are some instructions on the 'help' screen (click the button). You need to install the Microsoft speech recognition runtime and English language pack - the help screen should have URLs for these

  6. #6

    Unhappy Talk to me

    Quote Originally Posted by mr_belowski View Post
    There are some instructions on the 'help' screen (click the button). You need to install the Microsoft speech recognition runtime and English language pack - the help screen should have URLs for these
    Did as you suggested, but talk to me mr....
    Crew cheif is not responing, the only thing I get is(raceroom win 10) two beeps crosing the start/finish line, Its now not saying it cant setup the engine.
    Code:
    18:48:16.860 : Unable to set default audio device
    18:48:16.860 : Exception message: Cannot find the requested data item, such as a data key or value.
    18:48:16.860 : Attempted to initialise speech engine - success = False
    18:48:16.891 : Attempting to initialise speech recognition for user specified location en
    18:48:16.907 : Success
    18:48:16.907 : Unable to set default audio device
    18:48:16.907 : Exception message: Cannot find the requested data item, such as a data key or value.
    18:48:16.907 : Attempted to initialise speech engine - success = False
    18:48:16.923 : Checking for updates
    18:48:17.845 : Check for updates completed
    not sure what the fault is mate, but as a clue 18:48:16.907 : Unable to set default audio device might be the thing.

  7. #7
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    1,132
    The app will use the default audio output device, which is set in the windows sound control panel. Normally windows will automatically select one to be default but perhaps you need to do this manually

  8. #8
    Quote Originally Posted by mr_belowski View Post
    The app will use the default audio output device, which is set in the windows sound control panel. Normally windows will automatically select one to be default but perhaps you need to do this manually
    Its set as default far as I can see......
    I get default replies(spotter no spotter messages)but nothing else.

    it seams confused
    Code:
    20:54:06.218 : Starting app
    20:54:06.265 : Set Race Room mode from previous launch
    20:54:06.265 : Minimum sound pack version = 105 using sound pack version 112, driver names version 114 and personalisations version 104
    20:54:06.280 : Preparing driver names
    20:54:06.280 : Prepare driver names completed
    20:54:06.280 : Preparing sound effects
    20:54:06.280 : Prepare sound effects completed
    20:54:06.280 : Preparing personalisations for selected name Al
    20:54:06.280 : Prepare personalisations completed
    20:54:06.280 : Preparing voice messages
    20:54:06.405 : Prepare voice message completed
    20:54:06.405 : Finished preparing sounds cache, loaded 1006 single sounds and 578 sound sets, with 267 active SoundPlayer objects
    20:54:06.405 : 90 sounds have personalisations
    20:54:06.405 : Reading driver name mappings
    20:54:06.405 : Read 1163 driver name mappings
    20:54:06.405 : Reading driver name mappings
    20:54:06.421 : Loading controller settings
    20:54:06.452 : Load controller settings complete
    20:54:06.452 : Attempting to initialise speech recognition for user specified location en
    20:54:06.499 : Success
    20:54:06.499 : Unable to set default audio device
    20:54:06.499 : Exception message: Cannot find the requested data item, such as a data key or value.
    20:54:06.499 : Attempted to initialise speech engine - success = False
    20:54:06.546 : Attempting to initialise speech recognition for user specified location en
    20:54:06.562 : Success
    20:54:06.577 : Unable to set default audio device
    20:54:06.577 : Exception message: Cannot find the requested data item, such as a data key or value.
    20:54:06.577 : Attempted to initialise speech engine - success = False
    20:54:06.687 : Checking for updates
    20:54:07.632 : Check for updates completed
    Last edited by oOBATOo; 04-09-2017 at 08:56 PM. Reason: added log

  9. #9
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    1,132
    so do you get regular messages, like 'green green green', and the 'radio check' at the start? You also need to set a default sound input (recording) device for speech recognition to work

  10. #10
    Just done a breif session I did not finish the race Igot,
    allsorted message when I first left the pit BOX
    I got Green green green
    And that was all dispite being told to spot......... .

    HIH Ive tried reinstalling CC but cant redownload the three green packages at the top says there all ready downloaded.
    thought you had a lot of driver names but only see about 10 in the list or less..

    no radio check

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •