Results 1 to 3 of 3

Thread: Important: spotter and voice recognition issues

  1. #1
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    1,017

    Important: spotter and voice recognition issues

    Folks,

    A few users have reported issues with the spotter where it behaves as if cars are 45 metres long, calling overlaps when you're way behind another car. We know what's causing this and the same issue may also be affecting voice recognition.

    In some cases the user's settings file can become altered in what we'll call "sub-optimal ways". This causes settings that should have a decimal point to lose this decimal point. So the spotter thinks cars are 45 metres long, instead of 4.5 metres. And the speech recogniser will only recognise a voice command if the probability of it being correct is 4, on a scale of 0 to 1. We think this is triggered by number format issues on some cultures - specifically cases the decimal separator is not a '.'. We're looking into it and will fix it, but it might take a while.

    If you find that the spotter is talking nonsense and / or the voice recognition doesn't work there are 2 things you can do. The safest option is to exit the app and delete the folder

    C:\Users\[user name\AppData\Local\Britton_IT_Ltd

    This will reset the app's settings to default - it may be necessary to do this again after the app's been updated.

    If you want to fix the issue without deleting anything, inside the Britton_IT_Ltd folder look for a folder with the current app version (it's under a folder called CrewChiefV4.exe_Url_ltwjk4vypogatqgrzioneuqoankc3s pb\ or something like that). The user.config file (a text file) contains all the saved settings. The ones that are may be wrong are:

    xxx_spotter_car_length (where xxx is the game - should be about 4.5)
    minimum_name_voice_recognition_confidence (should be between 0 and 1)
    minimum_voice_recognition_confidence (should be between 0 and 1)
    spotter_gap_for_clear (should be about 0.5)


    Sorry about this folks, and thanks to the people who've supplied info to help us track it down.

    Jim

  2. #2
    Nice write-up Jim

    I'll just add that average fuel consumption will not likely to work even after settings reset, because it specifically looks for a '.' in a value. The possible workaround for now it use English number format in OS regional settings. But as Jim said, we'll fix this for good.

  3. #3
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    1,017
    note to Jim: if you find yourself writing "this is a shit way to do this" in code comments, do it a less shit way

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •