Results 1 to 10 of 10

Thread: Tell Me The Gaps no longer working

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Junior Member
    Join Date
    Feb 2019
    Posts
    7

    Tell Me The Gaps no longer working

    Hi,

    In Project Cars 2 I always want gaps fore and aft enabled, "Tell me the gaps", however recently, last new months I guess, I barely ever get the gaps each time I cross the line. In response to my instruction "Tell me the gaps" I do get an "okay I'll tell you the gaps", however I pretty much never get the gap behind, and sometimes I do get the gap to the car ahead once per lap, but most of the time not. I have reset my settings back to default to ensure that it's not something I have broken by changing a setting, however I still do not get anything. I can asked specifically "what's the gap behind?" and that works fine. Also it would be great if there was a tick box in the properties to just enable this constantly, it's like having a pitboard giving the gap behind and ahead which is pretty useful for adjusting your pace etc.

    I have also tried putting the gaps ahead and behind up to 10, however that didn't appear to make any difference. I'm not sure if it's thinking that I am in qualifying instead of a race as it typically tells me my splits and how much I am off the pace or not, which during a race with variable tyre state and fuel loads, I don't really care about anyway.

    Many thanks for this awesome bit of software btw, as a fellow developer I am really impressed and it makes Project Cars so much more enjoyable.

  2. #2
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    1,510
    I've been noticing a similar thing recently. I'll take a look when I get a chance

  3. #3
    Junior Member
    Join Date
    Feb 2019
    Posts
    7
    Hello,

    Is there any news on this? I note that it still does not work at all. I would love to have my gaps each lap, for me it's the most useful part of crew chief.

  4. #4
    Junior Member
    Join Date
    Feb 2019
    Posts
    7
    I did some testing and I think that instead of gaps in front and behind, he's giving deltas from the best lap during the race.

    If this cannot be fixed, it is possible to get previous builds?

  5. #5
    Crew Chief Mega Corp CEO mr_belowski's Avatar
    Join Date
    Feb 2017
    Posts
    1,510
    I've just testing this on pCars2 and I've been able to reproduce a bug, but I'm not sure if it's sufficient to cover what you're seeing.

    There's a piece of validation on the gap-ahead / gap-behind calls, intended to prevent them playing if your race position has changed since the message was 'queued', or if the gap is very small relative to your current speed. This issue here is that validation is too strict - if either of the gaps (ahead or behind) is too small, it won't play the messages. This is compounded by the fact that being in the lead means the gap ahead is 0 (so no gap messages play) and being last means the gap behind is zero (so again, no messages play).

    The upshot of all this is that it's far too likely for the gap messages to be considered invalid and not be played.

    A fix for this will be in the next version of the app. Hopefully it'll address your issue

  6. #6
    Junior Member
    Join Date
    Feb 2019
    Posts
    7
    Quote Originally Posted by mr_belowski View Post
    I've just testing this on pCars2 and I've been able to reproduce a bug, but I'm not sure if it's sufficient to cover what you're seeing.

    There's a piece of validation on the gap-ahead / gap-behind calls, intended to prevent them playing if your race position has changed since the message was 'queued', or if the gap is very small relative to your current speed. This issue here is that validation is too strict - if either of the gaps (ahead or behind) is too small, it won't play the messages. This is compounded by the fact that being in the lead means the gap ahead is 0 (so no gap messages play) and being last means the gap behind is zero (so again, no messages play).

    The upshot of all this is that it's far too likely for the gap messages to be considered invalid and not be played.

    A fix for this will be in the next version of the app. Hopefully it'll address your issue

    I am getting the messages now, in fact it is better than before, I think before you have the fore/aft gaps no matter if they were very small. Now I am hearing the gap ahead and my last lap time, not the gap behind because the A.I. car is usually close behind as I am holding them up. I have an online race event tonight again so it will get a proper test then. Fingers crossed and many thanks indeed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •