PDA

View Full Version : Voice recognition working - responses "not" working



jono-iracing
06-25-2018, 08:05 AM
Hi there

Finally got voice recognition to work... However I say something like "what's my gap behind" I do not get a response. If I say something CC4 doesn't understand it says it doesn't understand... Below is the extract from the log for what happens when I press listen to the time I release. CC Build is the latest.

14:42:25.347 : Listening for voice command...
14:42:25.353 : Opened channel - waiting for speech
14:42:25.353 : Getting audio from nAudio input stream
14:42:27.471 : Invoking speech recognition...
14:42:27.477 : Cancelling wait for speech
14:42:27.514 : Recognised : what's my gap behind confidence = 0.783
14:42:27.525 : Clip acknowledge/no_data is not valid



Thanks
Jon

mr_belowski
06-25-2018, 10:50 AM
Are you actually in a race session when you make that request?

jono-iracing
06-26-2018, 12:16 AM
Are you actually in a race session when you make that request?

I wasn't in a race session, was in practice. FYI tried quite a few alternatives with same result.

SonderRacing
06-27-2018, 09:15 PM
I'm seeing the same behavior. I'm always returned with Clip acknowledge/no_data though. I'm not sure if CrewChief isn't reading my telemetry right or what, but all of the output about tire wear/temps all read out to 0. I can never calculate fuel, or anything like that actually.

I'm not sure if this is related to the option to log 360Hz telemetry? I truly doubt that, but I do have that option turned off. I tested with it on and no difference anyways.

Crew Chief is connected to iRacing as I get spotter functionality, but as far as telemetry about fuel/tire/car status, I'm not getting anything back. Strange stuff.

Best,
Scott

diggusa
09-19-2018, 02:46 PM
No response from crew chief when asking for (Damage Report). Do I need to turn on something in properties to make it work? All other commands are working I think. BTW GREAT APP!

The Iron Wolf
09-20-2018, 12:20 AM
No response from crew chief when asking for (Damage Report). Do I need to turn on something in properties to make it work? All other commands are working I think. BTW GREAT APP!

iRacing does not expose damage information, so CC damage messages do not work with it.