PDA

View Full Version : CrewChief not starting anymore



Robin
04-10-2018, 07:10 AM
Suddenly CrewChief doesn't want to run anymore.
This is from my Windows logs:

Application: CrewChiefV4.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.IO.FileNotFoundException
at System.IO.__Error.WinIOError(Int32, System.String)
at System.IO.FileStream.Init(System.String, System.IO.FileMode, System.IO.FileAccess, Int32, Boolean, System.IO.FileShare, Int32, System.IO.FileOptions, SECURITY_ATTRIBUTES, System.String, Boolean, Boolean, Boolean)
at System.IO.FileStream..ctor(System.String, System.IO.FileMode, System.IO.FileAccess, System.IO.FileShare)
at NAudio.Wave.WaveFileReader..ctor(System.String)
at CrewChiefV4.Audio.NAudioBackgroundPlayer.initReade r(System.String)
at CrewChiefV4.Audio.NAudioBackgroundPlayer.initialis e(System.String)
at CrewChiefV4.Audio.AudioPlayer.initialise()
at CrewChiefV4.CrewChief..ctor()
at CrewChiefV4.MainWindow..ctor()
at CrewChiefV4.Program.Main()

Naam van toepassing met fout: CrewChiefV4.exe, versie: 1.0.0.0, tijdstempel: 0x5ac90254
Naam van module met fout: KERNELBASE.dll, versie: 10.0.16299.309, tijdstempel: 0x90a96867
Uitzonderingscode: 0xe0434352
Foutmarge: 0x0000000000014008
Id van proces met fout: 0x2080
Starttijd van toepassing met fout: 0x01d3d09a87d73c51
Pad naar toepassing met fout: C:\Program Files (x86)\Britton IT Ltd\CrewChiefV4\CrewChiefV4.exe
Pad naar module met fout: C:\WINDOWS\System32\KERNELBASE.dll
Rapport-id: b8c96ba4-c5e5-4d7e-9d4b-9f8eebb8da55
Volledige pakketnaam met fout:
Relatieve toepassings-id van pakket met fout:


Any ideas?

I'll try and reïnstall it, but I thought I'd post it here because it might be interesting for you...

Cheers,
Robin

Robin
04-10-2018, 07:15 AM
Just reïnstalled and still having the same issue.
Any suggestion as to my next move are very welcome. Thanks!

Cheers!

mr_belowski
04-10-2018, 09:54 AM
that's weird. Looks like the sound pack is incomplete or there's something wrong with the background sound. Try removing your settings file clear out c:\Users\[user name]\AppData\local\Britton_IT_Ltd\ and restart the app. If that doesn't work, delete c:\Users\[user name]\AppData\local\CrewChiefV4\sounds\ folder and allow the app to re-download everything

Robin
04-10-2018, 09:54 AM
Quick followup...

I've found this thread on the forum: http://thecrewchief.org/showthread.php?374-error-report&highlight=kernelbase
And when I copy the files posted in that thread to my CrewChief folder, it works again.
It is, however, version 4.9.1.7. It keeps asking me to update, downloads the update but then fails to install anything. I mean, it presents me with the modify/repair/remove dialog with nothing in it. It doesn't matter what I choose (repair or modify), nothing changes and I'm presented with the same update message on the next restart.

Is it me or is it something with the latest version?

Something is definitely off, but for now, I'm glad I got my chief back up and running..

Cheers

Robin
04-10-2018, 09:55 AM
that's weird. Looks like the sound pack is incomplete or there's something wrong with the background sound. Try removing your settings file clear out c:\Users\[user name]\AppData\local\Britton_IT_Ltd\ and restart the app. If that doesn't work, delete c:\Users\[user name]\AppData\local\CrewChiefV4\sounds\ folder and allow the app to re-download everything

Okay, I'll try that! Thanks!



UPDATE:
That certainly did the trick! Thanks for the support!
Cheers!