PDA

View Full Version : Errors causing crewchief not to work with iRacing



AlwaysBeApexing
02-07-2018, 08:19 PM
I'm getting this constantly in the logs about every 2-3 seconds. Currently Crew Chief does not work with iRacing even after reinstalling. Other sims work fine.

23:04:10.889 : Error mapping game data: Object reference not set to an instance of an object., at CrewChiefV4.iRacing.iRacingGameStateMapper.mapToGa meStateData(Object memoryMappedFileStruct, GameStateData previousGameState)
at CrewChiefV4.CrewChief.Run(String filenameToRun, Boolean dumpToFile)

What should be the next step to debug?

I recently restored drive from backup, I'm wondering if it can be some sort of permissions issue. I just couldn't determine the problem from the error message.

Using 4.9.1.4

Sparten
02-07-2018, 08:25 PM
Are you tying to join a hosted session ? or a session that includes driver change ?

If your able to replicate the error can you please try and do http://thecrewchief.org/showthread.php?142-How-to-collect-Crew-Chief-repro-traces and upload the file here.

AlwaysBeApexing
02-07-2018, 11:34 PM
This is my second post to enable link sharing :)

AlwaysBeApexing
02-07-2018, 11:36 PM
As requested: Logfile (https://drive.google.com/open?id=1bXjrEs58xZnt3yA8dgOM_MtN09fnkrIG)

This log is from one lap in a Time Trial. I have the errors present in any race or practice I run.

Sparten
02-08-2018, 06:50 AM
Thanks a lot, I've now tracked down the issue at least for this session type(lone practice) and it will be fixed in next update of the app.(wont take to long)

AlwaysBeApexing
02-08-2018, 10:34 PM
Cool, let me know if you would like me to test.