PDA

View Full Version : Spotter goes mute after a driver swap



Vindis
11-18-2017, 10:49 PM
As the title says it seems like there is an issue with driver swaps. Not sure if this is a issue with CC or the shared memory plugin.
He doesn't go completely mute but most of the time he's not saying a word, then all of a sudden he start giving me some information for a lap or so then he's all silent for a long time again.

Anyone else having this issue and is there something I can do about it. Someone at the S397 forum suggested to complete the driver swap first and then quickly tab out and click the start button but rf2 is too unstable to tab out of imo and even if it works it's still seconds lost. If you can't figure out what the issue is maybe you could you add a hotkey for the start button for a future release? That would help a ton.

Thanks for this amazing tool, feels great to have it available for all my sims <3

The Iron Wolf
11-19-2017, 04:49 AM
Hi Vindis,
Thanks for reporting this issue. Most likely, the problem is with rF2 implementation of CC, because plugin does not have any logic that affects CC behavior. I personally do not race online in rF2 and I am not familiar with driver swaps. But, I might be able to fix/improve this with some help. First, could you please explain the whole sequence of driver swap, when is CC started, when is swap happening etc, all the details (is it same PC?).

Second, please follow steps here http://thecrewchief.org/showthread.php?142-How-to-collect-Crew-Chief-repro-traces on how to capture the repro steps, and let me know on which lap/time swap happened.

In the worst case, we could add "restart" CC button, but I'd really like to avoid that and instead fix the problem correctly.