PDA

View Full Version : Race Finish Sounds



tmansteve
08-31-2017, 03:31 PM
At the finish of a race in rFactor, I have to wait until I am in the pits before I hear anything. The racestart is OK but would like to know if this can be fixed or if this is the way it is?

Sorry to be a pain

Cheers

Steve

The Iron Wolf
08-31-2017, 03:43 PM
At the finish of a race in rFactor, I have to wait until I am in the pits before I hear anything. The racestart is OK but would like to know if this can be fixed or if this is the way it is?

Sorry to be a pain

Cheers

Steve

Steve, I believe this is known issue, but if you collect a repro trace that will help us to quickly investigate :) Do a quick race of 5 laps, collect from the very beginning to pits, trace shouldn't be too huge.

tmansteve
08-31-2017, 03:55 PM
OK, will do. Thanks

tmansteve
08-31-2017, 04:45 PM
OK, here's the link. I had a 5 lap race and all was great. At the finish nothing happened until I got to the first corner and hit escape to end the race. After that, I heard Jim saying great race etc. Before that, on a previous race, I did 2 further laps after finish with nothing, like I said before until I was in the Pits. Hope you can shed some light on it. Many thanks. Just remembered, didn't go tot the pits and also might do another later as when I did a qualifier before, I didn't hear anything. Oh well, hope this helps anyway

https://www.dropbox.com/sh/x8v1hcnmhlkuyo3/AACurDxub570q1mQPLJMywQua?dl=0

The Iron Wolf
08-31-2017, 04:57 PM
OK, here are the links. I had a 5 lap race and all was great. At the finish nothing happened until I got to the first corner and hit escape to end the race. After that, I heard Jim saying great race etc. Before that, on a previous race, I did 2 further laps after finish with nothing, like I said before until I was in the Pits. Hope you can shed some light on it. Many thanks. Any probs, ask

https://www.dropbox.com/sh/x8v1hcnmhlkuyo3/AACurDxub570q1mQPLJMywQua?dl=0
Thanks Steve, I will have a look this weekend or early next week. I do suspect all we'll have to do is to port rFactor 2 session end detection code into rF1/AMS, because I remember I fixed similar issue in rF2.

tmansteve
08-31-2017, 05:26 PM
Thanks, that will be great. Just had another go at the qualifier. Vocals were there but nothing at the end of qualifying. When I started the race Jim announced Pole Position at race start. Not sure if that's any help.

Cheers

mr_belowski
08-31-2017, 08:33 PM
wow.... sectors in the RF1 data are zero indexed but the mapper is doing something very silly :(

[edit]

scratch that. The data is actually really quite odd. We'll have to keep digging :)

mr_belowski
08-31-2017, 09:14 PM
righty, thanks to Vytautas' most excellent RF2 code and hard work, the fix for this has already been figured out and just needed moving over to the RF1 / AMS code. A beta with this fix is now available - see here: http://thecrewchief.org/showthread.php?38-Beta-Test-Thread&p=605&viewfull=1#post605

The Iron Wolf
08-31-2017, 09:39 PM
Thanks, that will be great. Just had another go at the qualifier. Vocals were there but nothing at the end of qualifying. When I started the race Jim announced Pole Position at race start. Not sure if that's any help.

Cheers
Speaking of qualifying, I did not test what happens if time of quali runs out, but if you click "finish session" rFactor 2 does not notify us in any way (and by experience, same will happen in rF1/AMS), so this looks like a limitation of a model, at least for the premature finish case.

tmansteve
08-31-2017, 10:33 PM
Many thanks. Downloaded and will test tomorrow and report back

tmansteve
09-01-2017, 04:11 PM
I uninstalled V4 and did a clean install including sounds etc of 4.7.9.1.....So not sure wether to stick with this or go back to last update.

Full qualifier and 5 lap race. In qualifying, I had a few Spotter Laps but nothing saying I was in Pole Position. Nothing saying Qualifying was over, even after entering Pits. At Racestart, No mention of Laps as with last update but rest was OK. Full Yellow was implemented after a crash but kept being told Blue Flag. When Pace Car entered Pits, all OK. On last lap, confusing Oil Temp callouts which made me laugh and wasn't a detriment. At Race Finish, as soon as I crossed the line, Congrats vocal.

I hope this is of some help to you. If you can think of anything that might help that would be great.

Steve

mr_belowski
09-01-2017, 04:58 PM
Well it sounds like we're making progress here but still have some way to go.

I know it's a pain, but as I don't have rf1 the only way I can dig deeper into these issues is with the trace data. An ideal trace would be one that includes practice, qual and race. The sessions only have to be a few minutes long but they all have to be completed (not accelerated time or ended early), and you have to drive in each of them. If you could also give me brief run-down of what happened that would really help (e.g session positions, yellow flags, etc).

The blue flag thing is very odd - the code for this is really simple. If a car is ahead of you in the race, but is 40 metres or less behind you on track, trigger a blue flag. So I can't really guess why it kept triggering.

Were the oil temp callouts on the last lap accurate? I know they're irrelevant because you're almost finished, but do you think the oil temp was actually high?

tmansteve
09-01-2017, 05:48 PM
The oil temps were, high then low on last lap. The blue flag was while I was behind the Pace Car and that could have triggered it as I got closer to it or the cars behind me got closer. I will do another race as you ask and gather the data. Haven't done a practice properly in rfactor so something new. I will have a look tonight and do a proper one tomorrow and post them up for you.

Update

Will do 2 Laps Practice, Full Qualify and 5 Laps Race

Cheers

The Iron Wolf
09-01-2017, 08:12 PM
The oil temps were, high then low on last lap. The blue flag was while I was behind the Pace Car and that could have triggered it as I got closer to it or the cars behind me got closer. I will do another race as you ask and gather the data. Haven't done a practice properly in rfactor so something new. I will have a look tonight and do a proper one tomorrow and post them up for you.

Update

Will do 2 Laps Practice, Full Qualify and 5 Laps Race

Cheers
Blue flag under FCY is a simple bug that's already fixed in rF2, we'll port it to rF1.

The Iron Wolf
09-01-2017, 08:19 PM
BTW, speaking of oil temps I noticed (from the previous trace) that you are using unmapped car clases (basically, it makes CC to pick default temperature ranges). You can map your series to your class or ask us to do it and be able to configure oil temp ranges.

default max safe oil temp is:
#"maxSafeOilTemp":125
(celsius)

If you're interested in configuring that here's the info: http://thecrewchief.org/showthread.php?27-Customizing-Car-Classes it's a bit complicated, and even I don't fully understand how it works :) but it is a side effect of the need to be flexible for all the possible content

tmansteve
09-01-2017, 11:33 PM
Thanks for the info. I will be looking into that. Thanks for sorting the bug fix for blue flag. This is such an interesting app

tmansteve
09-02-2017, 06:06 PM
https://www.dropbox.com/sh/x8v1hcnmhlkuyo3/AACurDxub570q1mQPLJMywQua?dl=0

OK, did 6 Lap Practice, Full Qualifying, and 5 Lap Race. One thing I have to say is that I noticed in rFactor there is a Finish Session button beside the Next Session button (always used Next Session). So for this test, I used Finish Session, then selected Next Session to move on.

Practice Session Callouts were great. Came into Pits and then selected Finish Session and the callout came End of Practice and Pole Position.

Qualifying Session went well with P1 callouts and good Pit lane traffic callouts. One thing was when a Blue Flag came up on screen, I had no callout (Not sure if there is one) but was told which side it was on. Came into Pits for a repair and while waiting, I was told what Lap time the guy behind had done (No worries with that one). After the end of the session, selected Finish Session again and was congratulated on Pole Position.

Race Session, at beginning, I was told my position and then to get ready etc all ok. During the race, was told that there was a yellow in a sector but no yellow flag on screen, again it didn't detract from race. Callouts were great and at finish, Congrats callout was there as soon as I crossed the line.

I think maybe a lot of it was down to not selecting Finish Session and continuing that way so that the app had an understanding of start and finish etc.

One other thing, rFactor went to black screen twice. During Practice and the during Qualifying.

Hope this all helps Jim and you.

The Iron Wolf
09-03-2017, 01:08 AM
Speaking of game called Blue flag (when you see the icon), I checked yesterday when I was porting rF2 stuff, and I don't think rF1/AMS internals model exposes that, so I doubt we'd be able to fix it.

tmansteve
09-03-2017, 09:58 AM
Thats fine. Blue flag is nothing really. All I hope is that the info I have given is of some help.

mr_belowski
09-03-2017, 10:36 AM
From what I can see, the trace you sent behaves well except for the minor issues we've already talked about. Unless I'm missing something?

I think I have a work around for the 'next session' issue so you can skip with finishing and the app will behave properly. But we need to review it properly

tmansteve
09-03-2017, 03:31 PM
Thanks for that. Glad you haven't found anything bad. I don't mind if I don't have to skip the Finish Button.

mr_belowski
09-05-2017, 07:16 PM
New beta is out which should cope with pressing 'next session' without needing to press 'end session' first

tmansteve
09-07-2017, 06:46 PM
Thanks for letting me know. Will update asap. Will i have to download 4.7.9.2 or will 4.7.9.1 update automatically?

Cheers

mr_belowski
09-07-2017, 06:58 PM
you'll have to download it manually - only official releases are autoupdating. But once this release (or the next one) is 'official' the autoupdater will ensure you have the latest

tmansteve
09-07-2017, 07:22 PM
Ok. Thanks

mr_belowski
09-07-2017, 07:23 PM
there'll be an official version of this soon (tonight or tomorrow) - I'm just reworking some impossibly rubbish and buggy fuel code

tmansteve
09-11-2017, 03:57 PM
Works a treat so far.