PDA

View Full Version : A certain mod track in Assetto Corsa gives errors



transwarphub
02-25-2019, 01:39 PM
The Riverside(version 1.1) mod in Assetto Corsa has four variations and one of them the long version gives errors in crewchief after a couple of lapes. The crewchief nor the spotter give feedback anymore after the first error.

Is this something for crewchief or the modder?

mr_belowski
02-25-2019, 04:35 PM
Post the console output and I'll have a look

transwarphub
02-25-2019, 05:16 PM
This is the first part after that he keeps on giving the same error over and over agian.

mr_belowski
02-25-2019, 07:39 PM
it's hard to know the root cause of this, but some mode tracks do report an unusual number of sectors per lap. I'll force the app to use 2 or 3 sectors per lap for tracks it doesn't recognise (if the track says it's got 2 sectors, use 2, in all other cases use 3) and this will (probably...) address the issue. I can't test it myself because I can't download Riverside from Racedepartment without disabling my ad blocker, and Racedepartment has been infested with some pretty scummy ads recently so I'm not going anywhere near the place without adequate protection.

A debug trace would help massively here: http://thecrewchief.org/showthread.php?142-How-to-collect-Crew-Chief-repro-traces&highlight=debug

transwarphub
02-26-2019, 06:05 AM
You know that this site is using http which makes it less save and secure than racedepartment no mather what? Don't take this the wrong way but I just find your reply a bit odd. If you use Firefox with an ad-blocker you can download the track no problem.

I will make the debug trace log tonight when I get back home.

mr_belowski
02-26-2019, 06:11 AM
Thanks.

Regarding the site, we should probably switch to HTTPS at some point, but there's no personal or otherwise sensitive information here apart from passwords. RD knowingly hosts ads which contain dangerous and unpleasant scripts and the site activity prevents downloads if you have an ad blocker in chrome. Seems reasonable to be wary of the place

transwarphub
02-26-2019, 04:06 PM
https://drive.google.com/file/d/1m9ol0OfUCvJ8um5sPXwNI5Z5PmNwQ-yc/view?usp=drivesdk

mr_belowski
02-26-2019, 04:34 PM
Thanks fella, I'll take a look later

mr_belowski
02-26-2019, 06:23 PM
very helpful trace - it identified the underlying issue and I've released an update with a workaround

transwarphub
02-27-2019, 04:50 AM
I did a quick race this morning before I left and the issue has been resolved, thanks.